There have been multiple accounts created with the sole purpose of posting advertisement posts or replies containing unsolicited advertising.

Accounts which solely post advertisements, or persistently post them may be terminated.

programmer_humor

This magazine is from a federated server and may be incomplete. Browse more on the original instance.

lurch , in Old timers know

okay, but why did you use a password when the ssh/sftp key is right next to the files

lvxferre , in Sysadmin comes out of the goon cave. And he is not happy in the slightest.
@lvxferre@mander.xyz avatar

The alt text is nice, too: The weird sense of duty really good sysadmins have can border on the sociopathic, but it’s nice to know that it stands between the forces of darkness and your cat blog’s servers.

redcalcium , in new preference war just dropped

I’m truly torn with this. The first one seems sensible (action -> target) and easier to read and reason about (especially with long names), while the other one looks more organized, naturally sortable and works great with any autocompletion system.

kunaltyagi ,

We need a new framework, one that allows universal lookup, and makes life easier


<span style="color:#323232;">x = _.dialog.file.open
</span><span style="color:#323232;">y = _.open.file.dialog
</span><span style="color:#323232;">z = _.file.open.dialog
</span><span style="color:#323232;">a = _.file.dialog.open
</span>

Once done, the formatter simply changes everything to _.open.file.dialog

Let’s get this done JS peeps

\s

Ziglin ,

Aahh you can’t just make this problem object oriented!

C programmers don’t like that.

_g_be ,

Insert xkcd about 15th format

Rainb0wSkeppy ,
And009 ,

Not a programmer, but I’d prefer right naming convention because sorting

Lightfire228 ,

I am a programmer, and i also like the naming scheme on the right

Especially for things like filenames

bitwolf ,

Also a programmer and think method names would be conducive using little endian.


<span style="color:#323232;">TopicGet()
</span><span style="color:#323232;">TopicCreate()
</span><span style="color:#323232;">TopicDelete()
</span>

Writing this I realize we do this implicitly in some instances.


<span style="color:#323232;">http.Get() -> httpGet()
</span><span style="color:#323232;">http.Post() -> httpPost()
</span>
30p87 , in It's called attaining divinity

In the modern world it’s completely subjective.
The lowest-level language is probably ASM/machine code, as many people at least edit that regularly, and the highest-level would be LLMs. They are the shittiest way to program, yes, but technically you just enter instructions and the LLM outputs eg. Python, which is then compiled to bytecode and run. Similar to how eg. Java works. And that’s the subjective part; many people (me included) don’t use LLMs as the only way to program, or only use them for convenience and some help, therefore the highest level language is probably either some drag-and-drop UI stuff (like scratch), or Python/JS. And the lowest level is either C/C++ (because “no one uses ASM anyway”), or straight up machine code.

abbadon420 , in Old timers know

Did it for the first time two years ago. It was for my parent’s business website. I see nothing wrong with this method.

Seasm0ke , in Old timers know

Cries in REST API

yeather , in Someone escaped the Matrix

Don’t be fooled he’s going out there to hsck tractors now.

Kowowow ,

Spend years automating small farm tasks that take minutes

uis ,
uis , (edited )
starman , in COMEFROM
@starman@programming.dev avatar

Looks like C# 12 interceptors:


<span style="color:#323232;">[InterceptsLocation(@"C:testappProgram.cs", line: 4, column: 5)]
</span>

I know it looks awful, but it’s not intended for direct use, but rather for source generators for native ahead of time compilation.

andrewlock.net/exploring-the-dotnet-8-preview-cha…

match , in Someone escaped the Matrix
@match@pawb.social avatar

ooh, has anyone made something that transfers ownership of unmaintained codebases via bug bounty? like a sword-in-the-stone for critical fixes?

Daxtron2 ,

Just fork it

fibojoly , in Someone escaped the Matrix

One of my colleague is leader of the team managing our internal software systems, but also a potato farmer. Somehow.

abbadon420 ,

I have some chickens and some cows. It’s easy to combine small scale with wfh. Just need to move soemwhere with land and wifi.

uis ,
state_electrician , in Someone escaped the Matrix

Farming is god-awful if your livelihood depends on it. I’d rather be a carpenter or a metalworker once I’m fed up with that computer stuff.

uis ,

Wielders are paid close to programmers in my country

onlinepersona , in COMEFROM

I honestly thought C++ (aka dumping ground of programming concepts) would implement this for “completeness”.

Anti Commercial-AI license

NeatNit ,

They should add it in C++26

uis ,

C++60

schnurrito , in COMEFROM

TBH I fail to see the significant difference between this and a function declaration.

sxan ,
@sxan@midwest.social avatar

Doesn’t it steal control flow? More like a break point, except you define where execution continues.

I wonder if it’s a compile error to have multiple conflicting COMEFROM statements, or if it’s random, kind of like Go’s select statement.

How awesome would it be to be able to steal the execution stack from arbitrary code; how much more awesome if it was indeterminate which of multiple conflicting COMEFROM frames received control! And if it included a state closure from the stolen frame?

Now I want this.

davidgro ,

I wonder if it’s a compile error to have multiple conflicting COMEFROM statements

I think there’s at least one INTERCAL implementation where that’s how you start multi-threading

palordrolap ,

I'd say it's more like setting up a handler for a callback, signal, interrupt or something along those lines.

Function declarations by themselves don't usually do that. Something else has to tell the system to run that function whenever the correct state occurs.

That doesn't account for unconditional come-froms.¸but I expect there'd have to be a label at the end of some code somewhere that would give a hint about shenanigans yet to occur. Frankly that'd be worse than a goto, but then, we knew that already.

polonius-rex ,

it's semantic

at the end of the day everything boils down to sequence and branchifs

magic_lobster_party ,
print(A)
print(B)
hello: print(C)
print(D)
print(E)
comefrom hello
print(F)

This will print A, B, C and then F. D and E will be skipped because of the comefrom.

sudo ,

Its like if subroutine bar could say its going to execute at line N of routine foo. But if you were just reading foo then you’d have no clue that it would happen.

You can simulate this effect with bad inheritance patterns.

Cethin ,

A function will be called by code and go to that point in code. To implement functions, you store necessary things to memory and goto the function definition. To implement that with comefrom you’d have to have a list of all the places that need to call the function as comefroms before the function definition. It’d be a mess to read. We almost never care where we are coming from. We care where we’re going to. We want to say “call function foo” not “foo takes control at line x.”

umbrella , in COMEFROM
@umbrella@lemmy.ml avatar

am i the only dumb fuck here who unironically likes this?

would make goto type situations much more usable

MindTraveller ,

It’s basically a simpler version of a callback

Cethin ,

I don’t see any case where this is better than a goto. A goto you can read progressively though. A comefrom you’d see written then have to track to that piece of code and remember there’s a potential hidden branch there.

Thcdenton , in COMEFROM
  • All
  • Subscribed
  • Moderated
  • Favorites
  • [email protected]
  • random
  • lifeLocal
  • goranko
  • All magazines