There have been multiple accounts created with the sole purpose of posting advertisement posts or replies containing unsolicited advertising.

Accounts which solely post advertisements, or persistently post them may be terminated.

programmer_humor

This magazine is from a federated server and may be incomplete. Browse more on the original instance.

Matty_r , in new preference war just dropped
@Matty_r@programming.dev avatar

The object/class/thing would normally be its own class file, the action would be a method/function of said class.

Ie:

fileDialog.open()

fileDialog = Class (Dialog), Subclass (FileDialog)

locuester ,

It’s referring to variable names. For example, you have a variable named fileDialog. I would prefer to have that named dialogFile.

nomadjoanne , in new preference war just dropped

Romance language word order noun_descriptor is the right way.

suction , in new preference war just dropped

Not new

cupcakezealot , in new preference war just dropped
@cupcakezealot@lemmy.blahaj.zone avatar

the people who chose the first one…who hurt you?

habl ,

I will

MechanicalJester ,

No one, it just makes sense.

You must be one of those “Throw your mother downstairs, the box of tissues” types.

Yoda sounded normal to you I bet.

loudWaterEnjoyer ,
@loudWaterEnjoyer@lemmy.dbzer0.com avatar

It makes sense until you write 30 methods to manipulate the data layer.

Lifter ,

Fuzzy search solves this pretty good

Swedneck ,
@Swedneck@discuss.tchncs.de avatar

reverse polish notation time

lightnsfw ,

Powershell

magnus , in Happy World Turtle Day! One of my favourite turtle-releated software development things is that Firefox console will show a little turtle icon on slow requests. Picture also related.

The Kame ipsec project (www.kame.net) has a turtle image which is animated if visited with an IPv6 address.

redcalcium , in new preference war just dropped

I’m truly torn with this. The first one seems sensible (action -> target) and easier to read and reason about (especially with long names), while the other one looks more organized, naturally sortable and works great with any autocompletion system.

kunaltyagi ,

We need a new framework, one that allows universal lookup, and makes life easier


<span style="color:#323232;">x = _.dialog.file.open
</span><span style="color:#323232;">y = _.open.file.dialog
</span><span style="color:#323232;">z = _.file.open.dialog
</span><span style="color:#323232;">a = _.file.dialog.open
</span>

Once done, the formatter simply changes everything to _.open.file.dialog

Let’s get this done JS peeps

\s

Ziglin ,

Aahh you can’t just make this problem object oriented!

C programmers don’t like that.

_g_be ,

Insert xkcd about 15th format

Rainb0wSkeppy ,
And009 ,

Not a programmer, but I’d prefer right naming convention because sorting

Lightfire228 ,

I am a programmer, and i also like the naming scheme on the right

Especially for things like filenames

bitwolf ,

Also a programmer and think method names would be conducive using little endian.


<span style="color:#323232;">TopicGet()
</span><span style="color:#323232;">TopicCreate()
</span><span style="color:#323232;">TopicDelete()
</span>

Writing this I realize we do this implicitly in some instances.


<span style="color:#323232;">http.Get() -> httpGet()
</span><span style="color:#323232;">http.Post() -> httpPost()
</span>
lorty , in new preference war just dropped
@lorty@lemmygrad.ml avatar

I know the second one is better, but I also know I’m terribly inconsistent with this stuff.

nexussapphire ,

Been learning to program and I’m refusing to use an lsp for the time being. I’m bad about using abbreviated names when I have to type over and over again(no auto complete). I’m at least using descriptive names for functions I use less than four times.

nikaaa , in new preference war just dropped

I personally prefer dialogs.FileDialog.open()

joyjoy , in new preference war just dropped

We just call those Smurf names.

RiQuY , in Hot Potato License

The secret license everyone gets while working for an enterprise. If the previous dude left, good luck changing anything.

raldone01 , in Hot Potato License

There are a few flaws.

There should be a clause forcing it to remain open source. Another clause should be that the license must not be changed. A warrenty and liability disclaimer would be also good. Otherwise a splendid license.

jnk ,

I would 100% use this HPL-v2 for all of my (temporary) foss projects. It’s just genius. I mean, good luck keeping track of the current owner, Nintendo lawyers.

roon , in new preference war just dropped
@roon@lemmy.ml avatar

Powershell has a lint warning for functions that don’t follow Verb-Noun format, and verbs here are a list of approved verbs lol

ArmokGoB , in Hot Potato License
somegeek , in Not really sure whether S-expressions or Python indentation-based scoping get more hate...

Python has one of the worst syntaxes out there

jarfil , in new preference war just dropped

Both:


<span style="color:#323232;">dialog_error = Dialog_plain.create_modal(error_text)
</span>

Variable and class names go from more general to more particular, functions begin with a verb.

Global functions are either “main”, or start with one of “debug”, “todo”, or “shit”.

  • All
  • Subscribed
  • Moderated
  • Favorites
  • [email protected]
  • random
  • lifeLocal
  • goranko
  • All magazines